API_​PrimArc

A primitive arc.

    typedef struct {
        API_Prim_Head      head;
        API_AttributeIndex ltypeInd;
        bool               solid;
        bool               whole;
        short              determination;
        bool               reflected;
        char               filler_1[7];
        double             penWeight;
        API_Coord          orig;
        double             r;
        double             begAng;
        double             endAng;
        double             angle;
        double             ratio;
    } API_PrimArc;

 

Members

head
General primitive element header.
ltypeInd
Line type attribute index.
solid
Filled with solid color?
whole
Whole arc?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

reflected API 14
If true then the direction of the arc is negative (clockwise).
penWeight
Thickness of the arc [mm].
orig
Origin of the arc.
r
Radius of the arc.
begAng
Beginning angle of the arc (CCW, from the horizontal axis).
endAng
End angle of the arc (CCW, from the horizontal axis).
angle
0.0, or the angle of the ‘a’ axis.
ratio
1.0, or ‘a/b’ of the ellipse.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_PrimElement, API_Prim_Head, API_Coord, API Types