A union containing all drawing primitives used with ACAPI_Element_ShapePrims and ACAPI_LibPart_ShapePrims.
typedef union { API_Prim_Head header; API_PrimPoint point; API_PrimLine line; API_PrimArc arc; API_PrimText text; API_PrimPLine pline; API_PrimTri tri; API_PrimPoly poly; API_PrimPict pict; API_CWallPanel panelKind; } API_PrimElement;
Members
- header
- General primitive element header.
- point
- A primitive point.
- line
- A primitive line.
- arc
- A primitive arc.
- text
- A primitive text.
- pline
- A primitive polyline.
- tri
- A primitive triangle.
- poly
- A primitive polygon.
- pict
- A picture inside a placed drawing element.
- panelKind
- The curtain wall panel is window or door type.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_Prim_Head
API_PrimPoint
API_PrimLine
API_PrimArc
API_PrimText
API_PrimPLine
API_PrimTri
API_PrimPoly
API_PrimPict
API Types
ShapePrimsProc
ACAPI_LibPart_GetHotspots