API_​PrimElemRef

Primitive element reference.

    typedef struct {
        API_Guid           guid;
        API_ElemType       type;
        short              drwIndex;
        short              filler_0;
        Int32              filler_1[2];
    } API_PrimElemRef;

 

Members

guid 18
Guid of the referenced element.
type
Type of the referenced element.
drwIndex 5.2
Drawing order index of the referenced element.

 

Remarks

Primitive element references can be passed e.g. for windows and doors, where they refer to the owning wall.

New in API 26 From version 26 the type of the typeID member was changed into API_ElemType.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_ElemType
ShapePrimsProc
API Types