API_​PrimHatchBorder

Hatch border for primitive elements.

    typedef struct {
        bool                     doFrame;
        bool                     filler_1[3];
        API_AttributeIndex       fillInd;
        API_ExtendedPenType      fillPen;
        short                    fillbkgPen;
        short                    transparency;
        short                    determination;
        short                    filler_2[3];
        API_RGBColor             fillRgb;
        API_RGBColor             fillbkgRgb;
        bool                     isGradient;
        bool                     isLinear;
        bool                     filler_3[6];
        API_HatchOrientation     hatchOrientation;
    } API_PrimHatchBorder;

 

Members

doFrame
The frame of the hatch is visible.
fillInd
Fill attribute index.
fillPen 20
(Overridden) pen attribute index for the fill lines. If this value is 1008 (RGB Pen), then the foreground color of the fill is defined in the fillRgb parameter.
fillbkgPen
Pen attribute index for the fill background. If this value is 1008 (RGB Pen), then the background color of the fill is defined in the fillbkgRgb parameter.
transparency Changed in API 12
determination 6.1
Fill category:
APIHatch_DraftingFills Default fill category. Drafting fills adopt the Drafting Fill settings chosen in Display Options.
APIHatch_CoverFills The Cover Fill category is assigned to the fills of Slabs, Roofs, Meshes and Zones on the floor plan. Cover fills adopt the Element Cover Fill settings chosen in Display Options.
APIHatch_CutFills The Cut Fill category is assigned to the fills of Cut Elements. Cut fills adopt the Cut Fill settings chosen in Display Options.
fillRgb Featuring API 10
Foreground color of the fill; valid only if fillPen is RGB Pen (value 1008).
fillbkgRgb Featuring API 10
Background color of the fill; valid only if fillbkgPen is RGB Pen (value 1008).
isGradient Featuring API 10
The hatch has gradient fill (from foreground to background color).
isLinear Featuring API 10
The fill gradient is linear, otherwise it is radial.
hatchOrientation Featuring API 13
Orientation and distortion parameters of the cover fill.

 

Remarks

This structure is used to pass parameters of the hatch to be drawn in the ShapePrimsProc callback function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Coord, API_RGBColor, API_ExtendedPenType
ShapePrimsProc
API Types