API_​PrimPLine

A primitive polyline.

    typedef struct {
        API_Prim_Head      head;
        API_AttributeIndex ltypeInd;
        short              determination;
        short              drawSegmentMode;
        Int32              nCoords;
        Int32              nArcs;
        double             penWeight;
    } API_PrimPLine;

 

Members

head
General primitive element header.
ltypeInd
Line type attribute index.
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

drawSegmentMode 21
Determine the draw segment mode of the polyline. 0 means draw segments one-by-one, 1 means draw segments continuously
nCoords
Number of vertices.
nArcs 17
Number of curves in the polyline.
penWeight
Thickness of the polyline segments in mm.

 

Remarks

The actual coordinates of the polyline vertices are passed in the par1 parameter of the ShapePrimsProc function. The par3 parameter contains the polyline arcs.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_PrimElement, API_Prim_Head, API Types