API_​PrimPoly

A primitive polygon.

    typedef struct {
        API_Prim_Head           head;
        API_AttributeIndex      ltypeInd;
        bool                    solid;
        bool                    useRgb;
        short                   determination;
        double                  penWeight;
        Int32                   nCoords;
        Int32                   nSubPolys;
        Int32                   nArcs;
        API_ExtendedPenType     fillPen;
        API_RGBColor            rgbColor;
    } API_PrimPoly;

 

Members

head
General primitive element header.
ltypeInd
Line type attribute index.
solid
Filled with solid color?
useRgb 13
Have to use rgbColor when it set.
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

penWeight
Thickness of the polygon segments in mm.
nCoords
Number of vertices.
nSubPolys
Number of closed subpolygons including the first one.
nArcs
Number of curves in the polygon.
fillPen 20
(Overridden) pen attribute of the fill.
rgbColor 13
The color of fill if useRgb is set.

 

Remarks

The actual coordinates of the polyline vertices are passed in the par1 parameter of the ShapePrimsProc function. The par2 and par3 parameters contain the polygon endpoints and the polygon arcs, as in API_Polygon.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_PrimElement, API_Prim_Head, API_ExtendedPenType
API Types