A primitive text.
typedef struct { API_Prim_Head head; short ind1; short ind2; short paramInd; short font; unsigned short faceBits; short effectBits; API_AnchorID anchor; API_JustID just; Int32 filler_1; API_Coord loc; double heightMM; double widthMM; double angle; double widthFactor; double charSpaceFactor; } API_PrimText;
Members
- head
- General primitive element header.
- ind1
- ind1 in array type parameter
- ind2
- ind2 in array type parameter
- paramInd
- additive parameter index. Non zero if the text generated by a TEXT2 GDL command with an argument referencing to a text type variable
- font
- Font attribute index.
- faceBits
-
Style of text:
APIFace_Plain
Plain text
APIFace_Bold
Bold
APIFace_Italic
Italic
APIFace_Underline
Underline
- effectBits
- Special text effects:
-
APIEffect_StrikeOut
Strikethrough text APIEffect_SuperScript
Superscript APIEffect_SubScript
Subscript APIEffect_Fractional
Fractional text (not used) APIEffect_Protected
Protected text (autotext reference) - anchor
- Anchor point of the text (see API_AnchorID).
- just
- Justification of the text (see API_JustID).
- loc
- Left-baseline position, including the
angle
. - heightMM
- Vertical size of text box in mm.
- widthMM
- Horizontal size of text box in mm.
- angle
- Angle of the text [radian].
- widthFactor
- Text width factor; 1.0 is 100%.
- charSpaceFactor
- Character spacing factor; 1.0 is 100%.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_PrimElement, API_Prim_Head, API_AnchorID, API_JustID, API_Coord
API Types