API_​PrimTri

A primitive triangle.

    typedef struct {
        API_Prim_Head      head;
        API_AttributeIndex ltypeInd;
        bool               solid;
        bool               filler_1;
        short              determination;
        double             penWeight;
        API_Coord          c[3];
    } API_PrimTri;

 

Members

head
General primitive element header.
ltypeInd
Line type attribute index.
solid
Filled with solid color?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

penWeight
Thickness of the triangle segments in mm.
c[3]
Coordinates of the triangle vertices.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_PrimElement, API_Prim_Head, API_Coord, API Types