API_​PrintPars

Printing parameters.

    typedef struct {
        short                  scale;
        bool                   grid;
        bool                   fixText;
        char                   printArea;
        bool                   printGhost;
        bool                   scaleToPaper;
        bool                   newSheet;
        bool                   allColorsToBlack;
        bool                   ditherOnPrinter;
        bool                   usePrinterRes;
        bool                   scaleFitToPage;
        API_AnchorID           printAlignment;
        bool                   isStamp;
        bool                   filler_1[31];
        API_PrintStampType     stamp;
        double                 top;
        double                 left;
        double                 bottom;
        double                 right;
    } API_PrintPars;

 

Members

scale
Printing scale [1..30000]. Ignored if printArea or scaleToPaper is true
grid
Print also the construction grid lines
fixText
Print text, arrowheads and scale-independent dashed lines and fills at the actual size defined in their settings dialogs, or proportionally enlarged or reduced to the printing scale
printArea
Print the whole drawing or 3D projection fitting onto a page or print the current zoom or the content of the current marquee area only

PrintArea_CurrentView

Print current zoom

PrintArea_EntireDrawing

Print entire drawing

PrintArea_Marquee 5.1

Print current marquee area

printGhost
Print the floor plan elements with or without the ghost floor plan elements
scaleToPaper
Scale the content of the area window to the size that fills the paper width completely in the horizontal direction (for formatted lists only)
newSheet
Begin printing each zone description or List page on a new sheet of paper (for formatted lists only)
allColorsToBlack
Print all elements in black (Windows only)
ditherOnPrinter
Simulate photorealistic image colors on printers with lower bit depths by dithering the colors in the available palette (Windows only)
usePrinterRes
Use printer resolution for pictures (Windows only)
scaleFitToPage
Recalculate scale for fit to page
printAlignment 5.1
Anchor point of the drawing
isStamp 5.1
Printing header/footer is switched on
stamp 5.1
Data of the header/footer stamp (valid only if isStamp is true)
top Featuring API 10
Position of the top edge of the printing area of the paper in meter (output only)
left Featuring API 10
Position of the left edge of the printing area of the paper in meter (output only)
bottom Featuring API 10
Position of the bottom edge of the printing area of the paper in meter (output only)
right Featuring API 10
Position of the right edge of the printing area of the paper in meter (output only)

 

Remarks

For the utilization of this structure see the APIDo_PrintID and the APIDo_PhotoRenderID automation functions.

Featuring API 10  You can retrieve the current printer settings with the APIEnv_GetPrinterParsID environment function.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Automate.h

 

See Also

API_AnchorID, API_PrintStampType
APIDo_PrintID, APIDo_PhotoRenderID
APIEnv_GetPrinterParsID
API Types