API_​PrintStampType

Printing header/footer parameters.

    typedef struct {
        bool             addProjectName;
        bool             addProjectPath;
        bool             addViewName;
        bool             addLayerComb;
        bool             addDispOptComb;
        bool             addPrintingScale;
        bool             addLoginName;
        bool             addDateTime;
        bool             addPageNumber;
        bool             addCustomText;
        bool             filler_1[6];
        char             customText[256];
        API_AnchorID     position;
        short            fontID;
        short            filler_2;
        double           fontHeight;
        Int32            filler_3[8];
    } API_PrintStampType;

 

Members

addProjectName
Add project’s name to stamp
addProjectPath
Add project’s path to stamp
addViewName
Add view’s name to stamp
addLayerComb
Add layers combination to stamp
addDispOptComb
Add displayoptions combination to stamp
addPrintingScale
Add scale value to stamp
addLoginName
Add login name to stamp
addDateTime
Add current date and time to stamp
addPageNumber
Add pagenumber to stamp
addCustomText
Add custom text to stamp
customText
User text
position
Position of the stamp. Invalid positions: APIAnc_LM, APIAnc_MM, APIAnc_RM
fontID
Index of the stampfont
fontHeight
Height of the stampfont in MM

 

Remarks

For the utilization of this structure see the API_PrintPars structure.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Automate.h

 

See Also

API_PrintPars
APIDo_PrintID
APIDo_PhotoRenderID
API Types