Attribute representing the custom profiles for walls, beams, and columns.
typedef struct { API_Attr_Head head; bool wallType; bool beamType; bool coluType; bool handrailType; bool otherGDLObjectType; bool filler_1; bool filler_2; bool filler_3; Int32 filler_4[7]; } API_ProfileAttrType;
Members
- head
- The attribute header.
- wallType
- Profile available for walls.
- beamType
- Profile available for beams.
- coluType
- Profile available for columns.
- handrailType
- Profile available for handrails.
- otherGDLObjectType
- Profile available for other GDL based objects.
Remarks
Additional data for this attribute is contained in the profile_vectorImageItems
field of the API_AttributeDefExt structure. This extended data holds simple 2D elements: hotspots, lines, arcs, hatches, splines, texts, and images in a serialized form.
A simple example for creating and parsing a profile attribute can be found in the Attribute_Test example.
The flags
in ProfileItem
of ProfileFillData
(the profile description) may have the following values:
Value
Description
APISkin_HatchAngle
The fill direction is determined by the project origin (if not set), or the element’s origin (if set).
APISkin_Core
The skin’s fill is part of the core.
APISkin_Finish
The skin’s fill is part of the finish.
APISkin_HatchFit
The skin’s fill is distorted to fit the skin’s polygon.
Requirements
- Version: API 10 or later
- Header: APIdefs_Attributes.h