Contains information about the current project.
typedef struct { bool untitled; bool teamwork; short userId; Int32 workGroupMode; IO::Location *location; IO::Location *location_team; UInt64 modiStamp; GS::UniString *projectPath; GS::UniString *projectName; } API_ProjectInfo;
Members
- untitled
- Indicates that the project file not saved yet.
- teamwork
- Signed into a team project or not.
- userId
- team project member ID; if signed into a team project.
- workGroupMode
- team project member rights; if signed into a team project
- location
- the project file
- location_team
- the shared project file; if signed into a team project.
- modiStamp
- Modification stamp of project.
- projectPath
- optional; location of the project.
- projectName
- optional; name of the project.
Remarks
This structure is used to get several information about the current project.
Call the ACAPI_Environment function with the APIEnv_ProjectID function code to get this data.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Environment.h