API_​ProjectNoteInfo

Project note information parameters.

    typedef struct {
        char     client [256];
        char     projectName [256];
        char     company [256];
        char     street [256];
        char     city [256];
        char     country [256];
        char     code [256];
        char     architect [256];
        char     draftsmen [256];
        char     projectStatus [256];
        char     dateOfIssue [256];
        char     keywords [256];
        char     notes [1024];
    } API_ProjectNoteInfo;

 

Members

client
The name of the client.
projectName
The name of the project.
company
The company working on the project.
street
Street address.
city
City
country
State or country
code
Postal code
architect
Main architect(s)
draftsperson
Draftsperson
projectStatus
Project status
dateOfIssue
Date of issue
keywords
Other keywords related to the project.
notes
Notes for the project info.

 

Remarks

This data structure has totally chnaged in API 10.

The members of the data structure correspond to the items of the “Project Info…” dialog of Archicad. This information can be used for autotext entries in text elements. See APIAny_GetAutoTextsID.

Call the ACAPI_Environment function with the APIEnv_GetProjectNotesID or the APIEnv_ChangeProjectNotesID function codes to operate on this data.

The same behavior can be achieved with the autotext functions: APIAny_GetAutoTextsID, APIAny_SetAnAutoTextID. The main difference is that the autotext functions work on Unicode strings, whereas the project notes functions use ANSI strings converted from Unicode with the application’s code page (Windows) or encoding (macintosh).

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_ChangeProjectNotesID, APIEnv_GetProjectNotesID, ACAPI_Environment,
APIAny_GetAutoTextsID, APIAny_GetAutoTextKeysID, APIAny_SetAnAutoTextID
API Types