A structure representing a property default value.
It holds either a basic property value or a list of expression strings.
typedef struct { API_PropertyValue basicValue; GS::Array<GS::UniString> propertyExpressions; bool hasExpression; } API_PropertyDefaultValue;
Members
- basicValue
- The basic default value when not using an expression. This content of this value is undefined when expression is used.
- propertyExpressions
- The list of expression strings in the default value. The content of this array is undefined when basic default value is used.
- hasExpression
- Specifies if the default value holds expression or not.
Requirements
- Version: API 22 or later
- Header: APIdefs_Properties.h