API_​PropertyGroup

A structure representing a property group.

    typedef struct {
        API_PropertyGroupType     groupType;
        API_Guid                  guid;
        GS::UniString             name;
        GS::UniString             description;
    } API_PropertyGroup;
    

 

Members

groupType API 21
The type of this property group

API_PropertyGroupType

Meaning

API_PropertyStaticBuiltInGroupType

All of the property definitions in this group are API_PropertyStaticBuiltInDefinitionType

API_PropertyDynamicBuiltInGroupType

All of the property definitions in this group are API_PropertyDynamicBuiltInDefinitionType

API_PropertyCustomGroupType

All of the property definitions in this group are API_PropertyCustomDefinitionType

guid
The unique identifier of the property group
name
The name of the property group
description API 25
The description of the property group

 

Requirements

Version: API 20 or later
Header: APIdefs_Properties.h

 

See Also

Properties,
API Types