API_​PropertyObjectParams

Defines parameters for the property handler function.

    typedef struct {
        API_PropertyObjectCmdID      cmd;
        GS::uchar_t                  propertyName[API_UniLongNameLen];
        char                         propertyUnID[128];
    } API_PropertyObjectParams;

 

Members

cmd
The identifier of the command the handler was called for. Its value can be: APIPropObj_None, APIPropObj_AssignProperty, or APIPropObj_DisableProperty.
propertyName API version 18
the name of the property to assign to the element, in UTF-16 encoding
propertyUnID API version 18
the UnID of the property to assign to the element

 

Remarks

See the example for APIPropertyObjectCommandProc.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

API Types