API_​PropertyValue

A container for storing a property’s value.

    typedef struct {
        API_SingleVariant                  singleVariant;
        API_ListVariant                    listVariant;
        API_VariantStatus                  variantStatus;
    } API_PropertyValue;
    

 

Members

singleVariant
The value of the property if the definition’s collectionType is API_PropertySingleCollectionType or API_PropertySingleChoiceEnumerationCollectionType. In case of enumeration, the keyVariant of the selected enum value is stored here (added in Changed in API 25).
listVariant
The value of the property if the definition’s collectionType is API_PropertyListCollectionType or API_PropertyMultipleChoiceEnumerationCollectionType. In case of enumeration, the keyVariant of the selected enum values are stored here (added in Changed in API 25).
variantStatusAPI 22
The status of the property’s currently valid value. If the status is not set to APIVariantStatusNormal, the property value is ignored.

 

Remarks

New in API 23  You can easily convert the evaluated property value to display string with the ACAPI_Property_GetPropertyValueString function.

Changed in API 25  In Archicad 25 the singleEnumVariant and multipleEnumVariant members were removed. In case of enumeration values the keyVariant of the selected enum value is stored in the singleVariant or listVariant member instead. If you need to, you can retrieve the displayVariant or nonLocalizedValue of the enumeration from the property definition’s possibleEnumValues member based on the stored keyVariant.

Requirements

Version: API 20 or later
Header: APIdefs_Properties.h

 

See Also

API_PropertyDefinition
API_Property
Properties