API_​PublishFormatData

Represents the data of a publisher format.

    typedef struct {
        GS::UniString                        mimeType;
        GS::UniString                        popUpText;
        GS::UniString                        fileExtText2D;
        GS::UniString                        fileExtText3D;
        GS::Array<API_WindowTypeID>          windowTypes;
        bool                                 singleFile;
        GS::Array<API_WindowTypeID>          windowTypesInSingleFile;
        short                                iconID;
    } API_PublishFormatData;

 

Members

mimeType
MimeType of the new publish format. The MimeType has to be unique.
popUpText
Popup text will be the name of the new publish format, on the publisher dialog.
fileExtText2D
File extension in case of 2D save.
fileExtText3D
File extension in case of 3D save.
windowTypes
Describes the new format in which windows is available.
singleFile
In case of true, the new registered format gives the possibility to merge all content in one file (like PDF format).
windowTypesInSingleFile
Describes, the new format in which windows are available in single file mode. If singleFile bool is false, this array has to be empty.
IconId
The resource ID of the new publisher format’s icon.

 

Requirements

Version: API 23 or later
Header: APIdefs_Registration.h

 

See Also

ACAPI_Register_PublishFormat
API_WindowTypeID
API Types