API_​Quantities

Describes the different calculated values for skins of composite or complex elements.

    class API_Quantities {
        API_ElementQuantity*                         elements;
        GS::Array<API_CompositeQuantity>*            composites;
        GS::Array<API_ElemPartQuantity>*             elemPartQuantities;
        GS::Array<API_ElemPartCompositeQuantity>*    elemPartComposites;
    };

 

Members

elements19
Quantity values for the specified part of the elem.
composites
Calculated values for skins of composite or complex elements.
elemPartQuantities
Calculated values for parts of an element. This is used only for Multi-plane Roof and Morph elements. In case of Roof it contains the quantity data for each plane roof segment. In case of Morph it contains the quantity data belongs to the floor identified by floor member of API_ElemPartId structure.
elemPartComposites
Calculated values for skins of composite or complex elements. This is used only for Roof element.

 

 

Requirements

Version: API 19.0 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types