Represents a radial dimension.
typedef struct { API_Elem_Head head; short linPen; short filler_1; API_TextPosID textPos; API_DirID textWay; bool showOrigo; bool onlyDimensionText; bool filler_2[2]; char prefix[8]; GS::UniString *prefixUStr; API_MarkerData markerData; Int32 filler_3[6]; API_NoteType note; API_DimBase base; API_Coord endC; double dimVal; Int32 filler_4[8]; } API_RadialDimensionType;
Members
- head
- General element header.
- linPen
- Pen attribute index of dimension and witness lines.
- textPos
- Dimension text position (see API_TextPosID).
- textWay
- The position of the text relative to the dimension line (see API_DirID). The possible values are:
APIDir_Horizontal
,APIDir_Vertical
,APIDir_Radial
. - showOrigo
- Show arc’s origin.
- onlyDimensionText
- Only dimension texts (notes) are visible — no leader line.
- prefix[8]
- Place this prefix before the number; example: R 7.55;
- prefixUStr
- Optional parameter for accessing the prefix in UniString format.
- markerData
- Marker specification (see API_MarkerData).
- note
- Note parameters (see API_NoteType).
- base
- Base element for the radial dimension.
- endC
- End of [radial] dimension line.
- dimVal
- Radius of dimensioned item.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_TextPosID, API_DirID, API_MarkerData, API_NoteType, API_DimBase, API_Coord, API_Element,
Element Manager, API Types