Represents a Baluster Set element.
typedef struct { API_Elem_Head head; API_Guid owner; API_Guid filler_1; API_RailingFrameData frame; API_RailingDistributionData distribution; API_RailingBalusterType defBaluster; UInt32 nBalusters; UInt32 filler_2; } API_RailingBalusterSetType;
Members
- head
- General element header.
- owner
- GUID of the Railing Pattern element owning this Baluster Set.
- frame
- Describes the boundaries of the Baluster Set.
- distribution
- Describes the distribution of Balusters in the Baluster Set.
- defBaluster
- The default Baluster element, from which the Baluster instances will be generated.
- nBalusters
- The amount of Balusters in the Baluster Set.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_Element,
API_RailingType,
API_RailingPatternType,
API_RailingFrameData,
API_RailingDistributionData
Element Manager,
API Types