Represents the distribution of some Railing subelements.
typedef struct { API_DistribTypeID type; API_PatternAlignID alignment; double length; UInt32 patternAmount; UInt32 filler_1; } API_RailingDistributionData;
Members
- type
-
Distribution of the given pattern:
APIDT_Divisions
Divide segment into
patternAmount
divisions.APIDT_PatternLength
Fixed pattern length.
APIDT_BestDivisionByLength
Equally distributed pattern. Maximal length is given by
length
. - alignment
-
Pattern origin position:
APIPA_StartWithPattern
Start with pattern.
APIPA_StartFromCenter
Start from center.
APIPA_CenterAligned
Aligned to center.
APIPA_EndWithPattern
End with pattern.
- length
- Length between divisions.
- patternAmount
- Amount of the given pattern’s repetitions.
- filler_1
- UNUSED PARAMETER
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h