API_​RailingFrameData

Represents the boundaries of a Railing subelement.

    typedef struct {
        double                         yOffset;
        double                         zTopOffset;
        double                         zBottomOffset;
        double                         xBeginOffset;
        double                         xEndOffset;
        UInt32                         placeIndex;
        UInt32                         filler_1;
        API_RailingVerticalPosData     verticalPosition;
    } API_RailingFrameData;

 

Members

yOffset
Horizontal offset from Segment, perpendicularly to the the plane of the segment.
zTopOffset
Offset from top Rail or the top of the Segment.
zBottomOffset
Offset from bottom Rail or the bottom of the Segment.
xBeginOffset
Offset from left Inner Post.
xEndOffset
Offset from right Inner Post.
placeIndex
Index of the left Inner Post.
verticalPosition
This structure describes the vertical position of the subelement.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_RailingType, API_RailingVerticalPosData
Element Manager, API Types