Represents an Inner Post element.
typedef struct { API_Elem_Head head; API_Guid owner; API_Guid symbID; double doublePostOffset; API_RailingVerticalPosData verticalPosition; API_RailingHorizontalPosData horizontalPosition; short postNum; short filler_1[3]; } API_RailingInnerPostType;
Members
- head
- General element header.
- owner
- GUID of the Railing Pattern element owning this Inner Post.
- symbID
- The identifier of the symbol of this element.
- doublePostOffset
- Offset of the Inner Posts from the pattern.
- verticalPosition
- Vertical alignment of this element.
- horizontalPosition
- Horizontal alignment of this element.
- postNum
- The amount of posts within this element (maximum of 2).
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_Element,
API_RailingType,
API_RailingPatternType,
API_RailingVerticalPosData,
API_RailingHorizontalPosData
Element Manager,
API Types