Represents a Railing Node element.
typedef struct { API_Elem_Head head; API_Guid owner; bool visible; bool unifyPatterns; bool isStatic; bool filler_1[5]; API_RailingPostType defPost; API_RailingRailEndType defRailEnd; API_RailingRailEndType defHandrailEnd[2]; API_RailingRailEndType defToprailEnd; API_RailingRailConnectionType defRailConnection; API_RailingRailConnectionType defHandrailConnection[2]; API_RailingRailConnectionType defToprailConnection; short visiblePostNum; short filler_2[3]; double elevation; double postOffset; UInt32 nRailConnections; UInt32 nRailEnds; bool autoConnectionOffset; bool tiltedPost; bool filler_3[6]; double connectionOffset; double endingOffset; } API_RailingNodeType;
Members
- head
- General element header.
- owner
- GUID of the Railing element owning this Railing Node.
- visible
- True, if the Railing Node is visible.
- unifyPatterns
- If unifyPatterns is false, than crop segment at Node, otherwise continue the pattern.
- isStatic
- True, if the Railing Node is static.
- defPost
- The default Railing Post element, from which the Railing Post instances will be generated.
- defRailEnd
- The default Rail End element, from which the default Rail End instances will be generated.
- defHandrailEnd
- The default Handrail End elements, from which the Handrail End instances will be generated.
- defToprailEnd
- The default Toprail End element, from which the Toprail End instances will be generated.
- defRailConnection
- The default Rail Connection element, from which the default Rail Connection instances will be generated.
- defHandrailConnection
- The default Handrail Connection elements, from which the Handrail Connection instances will be generated.
- defToprailConnection
- The default Toprail Connection element, from which the Toprail Connection instances will be generated.
- visiblePostNum
- Amount of visible posts.
- elevation
- Vertical offset.
- postOffset
- Post offset from Node.
- nRailConnections
- The number of Rail Connections.
- nRailEnds
- The number of Rail Ends.
- autoConnectionOffset
- .
- tiltedPost
- .
- connectionOffset
- .
- endingOffset
- .
Remarks
Railing Node elements contain Railing Posts, and Rail connections and endings. Each Node represents a vertex in the reference line of the railing.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_Element, API_RailingType,
API_RailingPostType,
API_RailingRailEndType,
API_RailingRailConnectionType
Element Manager, API Types