API_​RailingPanelType

Represents a Railing Panel element.

    typedef struct {
        API_Elem_Head            head;
        API_Guid                 owner;
        API_Guid                 symbID;
        bool                     visible;
        bool                     filler_1[7];
        API_RailingFrameData     frame;
    } API_RailingPanelType;

 

Members

head
General element header.
owner
GUID of the Railing Segment element owning this Railing Panel.
symbID
The identifier of the symbol of this element.
visible
True, if the Railing Panel is visible.
frame
Describes the boundaries of the Railing Panel.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingPatternType
Element Manager, API Types