API_​RailingPatternType

Represents a Railing Pattern element.

    typedef struct {
        API_Elem_Head                   head;
        API_Guid                        owner;
        API_RailingDistributionData     distribution;
        API_RailingPanelType            defPanel;
        API_RailingBalusterSetType      defBalusterSet;
        API_RailingInnerPostType        defInnerPost;
        UInt32                          nPanels;
        UInt32                          nBalusterSets;
        UInt32                          nInnerPosts;
        UInt32                          filler_1;
    } API_RailingPatternType;

 

Members

head
General element header.
owner
The owner railing this pattern belongs to.
distribution
Describes the distribution of the Pattern’s subelements.
defPanel
The default Railing Panel element, from which the Railing Panel instances will be generated.
defBalusterSet
The default Baluster Set element, from which the Baluster Set instances will be generated.
defInnerPost
The default Inner Post element, from which the Inner Post instances will be generated.
nPanels
Amount of Railing Panels in the Railing Pattern.
nBalusterSets
Amount of Baluster Sets in the Railing Pattern.
nInnerPosts
Amount of Inner Posts in the Railing Pattern.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingSegmentType
Element Manager, API Types