API_​RailingPostType

Represents a Railing Post element.

    typedef struct {
        API_Elem_Head                  head;
        API_Guid                       owner;
        API_Guid                       symbID;
        API_RailingVerticalPosData     verticalPosition;
    } API_RailingPostType;

 

Members

head
General element header.
owner
GUID of the Railing Node element owning this Railing Post.
symbID
The identifier of the symbol of this element.
verticalPosition
Vertical alignment of the Railing Post.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingNodeType, API_RailingVerticalPosData
Element Manager, API Types