API_​RailingRailConnectionType

Represents a connection between two Rail/Handrail/Toprail elements.

    typedef struct {
        API_Elem_Head                    head;
        API_Guid                         owner;
        API_Guid                         symbID;
        API_RailBaseBaseConnectionID     baseConnection;
        API_RailConnectionTypeID         type;
        double                           railEndOffset;
        double                           railEndFillet;
        double                           firstExtrusionLength;
        double                           secondExtrusionLength;
        double                           filler_1;
        double                           horizontalFillet;
        double                           gooseneckFillet;
        double                           gooseneckOffset;
        double                           verticalBottomFillet;
        double                           directFillet;
    } API_RailingRailConnectionType;

 

Members

head
General element header.
owner
GUID of the Railing Node element owning this Rail Connection.
symbID
The identifier of the symbol of this element.
baseConnection
Connection type between two Rail bases:

APIBB_Horizontal

Connection type is horizontal.

APIBB_Tangential

Connection type is tangential.

type
Connection type:

APICT_NoRailConnection

Disconnected.

APICT_GooseneckRailConnection

Gooseneck connection.

APICT_DirectRailConnection

Direct connection.

railEndOffset
Offset from the end of the rail.
railEndFillet
Fillet at the end of the rail.
firstExtrusionLength
Length of the first extrusion.
secondExtrusionLength
Length of the second extrusion.
horizontalFillet
Horizontal filleting.
gooseneckFillet
Gooseneck filleting.
gooseneckOffset
Gooseneck offset.
verticalBottomFillet
Vertical bottom filleting.
directFillet
Direct filleting.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingNodeType
Element Manager, API Types