API_​RailingRailEndType

Represents a Rail/Handrail/Toprail End element.

    typedef struct {
        API_Elem_Head                      head;
        API_Guid                           owner;
        API_Guid                           symbID;
        API_RailEndTypeID                  type;
        API_RailEndBaseConnectionID        baseConnection;
        double                             firstExtrusionOffset;
        double                             firstExtrusionLength;
        double                             filletRadius;
        API_RailEndFixtureConnectionID     fixtureConnection;
        API_RailEndArcAngleModeID          arcAngleMode;
        double                             arcAngle;
        double                             arcRadius;
        double                             secondExtrusionLength;
        double                             thirdExtrusionLength;
        API_RailEndExtrusionModeID         secondExtrusionMode;
        UInt32                             filler_1;
        API_RailingFinishType              finishDef;
    } API_RailingRailEndType;

 

Members

head
General element header.
owner
GUID of the Railing Node element owning this Rail End.
symbID
The identifier of the symbol of this element.
type
The type of the Rail End:

APIRE_Extension

The type is extension.

APIRE_Curve

The type is curved.

APIRE_FullReturn

The type is full return.

APIRE_ConnectWithDuplicate

The type is connection between duplicated handrails.

baseConnection
Connection type between the Rail End and a base:

APIBC_Horizontal

Connection type is horizontal.

APIBC_Tangential

Connection type is tangential.

firstExtrusionOffset
Offset of the first extrusion.
firstExtrusionLength
Length of the first extrusion.
filletRadius
Radius of the filleting of the Rail End.
fixtureConnection
The type of the curving in case of Curved type:

APIRC_SegmentPlane

The curving is in the plane of the segment.

APIRC_HorizontalRight

The curving is horizontal to the right.

APIRC_HorizontalLeft

The curving is horizontal to the left.

arcAngleMode
Angle mode of the Rail End’s arc:

APIAM_SetToVertical

The angle is absolute vertical.

APIAM_CustomAngle

The angle is relative to the first extrusion.

arcAngle
Angle of the Rail End’s arc.
arcRadius
Radius of the Rail End’s arc.
secondExtrusionLength
Length of the second extrusion.
thirdExtrusionLength
Length of the third extrusion.
secondExtrusionMode
Mode of the second extrusion:

APIEM_CustomLength

The length is custom.

APIEM_ToReferenceLine

The length of the extrusion will be set so that it will reach the reference line.

APIEM_ToHandrailSibling

In case of a handrail the length will be set so that it will reach the other handrail. If this is set for one of the handrails, then the other handrail’s secondExtrusionMode will be automatically set to APIEM_ToHandrailSibling, too.

lastCutAngle
Angle of the Rail End’s last cut.
finishDef
Default finish for the Rail End.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingNodeType
Element Manager, API Types