API_​RailingRailType

Represents a Rail element.

    typedef struct {
        API_Elem_Head     head;
        API_Guid          owner;
        API_Guid          symbID;
        bool              visible;
        bool              relative;
        bool              filler_1[6];
        double            horizontalOffset;
        double            height;
    } API_RailingRailType;

 

Members

head
General element header.
owner
GUID of the Railing Segment element owning this Rail.
symbID
The identifier of the symbol of this element.
visible
True, if the Rail is visible.
relative
True, if the Rail is relative.
horizontalOffset
The horizontal offset of the Rail from the Segment.
height
The height of the Rail element.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingSegmentType
Element Manager, API Types