Represents a Railing Segment element.
typedef struct { API_Elem_Head head; API_Guid owner; bool visible; bool relativeSkewingAngle; bool filler_1[2]; API_RailingRefLineLocationID refLineLocation; double height; double yOffset; double zOffset; double slantAngle; double skewAngle; API_RailingPatternType defPattern; API_RailingHandrailType defDefaultHandrail; API_RailingHandrailType defHandrails; API_RailingToprailType defToprail; API_RailingRailType defDefaultRail; API_RailingRailType defRails; } API_RailingSegmentType;
Members
- head
- General element header.
- owner
- GUID of the Railing element owning this Railing Node.
- visible
- True, if the Railing Segment is visible.
- relativeSkewingAngle
- True, if the skew angle of the Railing Segment is relative.
- refLineLocation
- The location of the segment’s reference line
APIRLL_Left
Reference line is on the left
APIRLL_Center
Reference line is at the centre
APIRLL_Right
Reference line is on the right
- height
- The height of the Railing Segment.
- yOffset
- Reference line offset.
- zOffset
- Railing vertical offset.
- slantAngle
- The slanting angle of the Railing Segment.
- skewAngle
- The skewing angle of the Railing Segment.
- defPattern
- The default Railing Pattern element, from which the Railing Pattern instances will be generated.
- defDefaultHandrail
- The default Handrail element, from which the upper Handrail instances will be generated.
- defHandrails
- The default Handrail element, from which the lower Handrail instances will be generated.
- defToprail
- The default Toprail element, from which the Toprail instances will be generated.
- defDefaultRail
- The default Rail element, from which the default Rail instances will be generated.
- defRails
- The default Rail element, from which the added Rail instances will be generated.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_Element, API_RailingType,
API_RailingPatternType, API_RailingHandrailType
API_RailingToprailType, API_RailingRailType
Element Manager, API Types