API_​RailingToprailType

Represents a Toprail element.

    typedef struct {
        API_Elem_Head     head;
        API_Guid          owner;
        API_Guid          symbID;
        bool              visible;
        bool              filler_1[7];
    } API_RailingToprailType;

 

Members

head
General element header.
owner
GUID of the Railing Segment element owning this Toprail.
symbID
The identifier of the symbol of this element.
visible
True, if the Rail is visible.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_RailingType, API_RailingSegmentType
Element Manager, API Types