API_​Rect

Rectangle in pixel coordinates.

    typedef struct {
        short     top;
        short     left;
        short     bottom;
        short     right;
    } API_Rect;

 

Members

top
top pixel (vertical) of the rectangle
left
left pixel (horizontal) of the rectangle
bottom
bottom pixel (vertical) of the rectangle
right
right pixel (horizontal) of the rectangle

 

Remarks

An integer type representation of an API_Box. Expressed in the local coordinates of the window, based on pixels from the top/left corner.

Refer to the APIDb_PointToCoordID and APIDb_CoordToPointID conversion functions for further details.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

APIDb_PointToCoordID, APIDb_CoordToPointID, API_Box, API Types