API_​RefLevelsPrefs

The representation of the Reference Levels on the Preferences / Working Units & Levels tab page.

    typedef struct {
        GS::UniString     *level1UStr;
        GS::UniString     *level2UStr;
        double            level1val;
        double            level2val;
    } API_RefLevelsPrefs;

 

Members

level1UStr
The name of the first reference level.
level2UStr
The name of the second reference level.
level1val
The value of the first reference level.
level2val
The value of the second reference level.

 

Remarks

This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Working Units & Levels preferences page.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetPreferencesID
API Types