API_​Region

Polygonal or rectangular region of the model.

    typedef struct {
        Int32         filler_1;
        Int32         nCoords;
        API_Coord     **coords;
        Int32         filler_2;
        API_Box       box;
        double        boxRotAngle;
    } API_Region;

 

Members

nCoords
number of coordinates (in case of polygonal representation)
coords
the coordinate handle (in case of polygonal representation)
box
the rectangle (in case rectangular representation)
boxRotAngle
the rotation angle (in case rectangular representation)

 

Remarks

It is a closed polygon expressed in model coordinates. Special representation can be a (rotated) rectangle. In the case of polygonal representation the data structure follows the rules specified in API_Polygon.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

API_Coord, API_Box, API_Polygon, APIDb_StartClippingSessionID, APIDb_StopClippingSessionID, API Types