The representation of the Rendering Settings / Brightness tab page.
typedef struct { API_RGBColor overRGB; short brightness; short overExpoCorrMethod; Int32 filler_1[15]; } API_RendBrightness;
Members
- overRGB
- Overexposure correction color
- brightness
- Brightness of the photorendered image. The value must be between -100 and 100; set negative values to darken, positive values to brighten the image, or zero to avoid brightness correction.
- overExpoCorrMethod
-
Method of overexposure correction; can be one of these values:
API_RendCorr_DarkenAllSurf
(darken all surfaces)API_RendCorr_DarkenOverExpSurf
(darken overexposed surfaces only)API_RendCorr_PaintOverExpSurf
(paint overexposed surfaces with theoverRGB
overexposure correction color)
Remarks
This structure is used by the APIEnv_GetRenderingSetsID and APIEnv_ChangeRenderingSetsID functions to get and modify the settings of the Brightness “Rendering Settings” tab page.
See an example of using this structure at the description of APIEnv_ChangeRenderingSetsID.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_GetRenderingSetsID, APIEnv_ChangeRenderingSetsID,
API_RendEffects, API_RendImage, API_RGBColor, API Types