The representation of the Rendering Settings / Effects tab page.
typedef struct { API_ModulID rendererID; bool useBkgAlpha; bool filler_1[7]; } API_RendEffects;
Members
- rendererID
- The module ID of the rendering engine.
- useBkgAlpha
- Use alpha channel for transparency
Remarks
This structure is used by the APIEnv_GetRenderingSetsID and APIEnv_ChangeRenderingSetsID functions to get and modify the settings of the Effects “Rendering Settings” tab page.
See an example of using this structure at the description of APIEnv_ChangeRenderingSetsID.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_GetRenderingSetsID, APIEnv_ChangeRenderingSetsID,
API_RendImage, API Types