The representation of the Rendering Settings / Size & Background tab page.
typedef struct { short hSize; short vSize; short outResolution; bool proportional; bool bkgPict; API_RGBColor bkgSkyRGB; API_RGBColor bkgEarthRGB; API_Rect bkgPictRect; IO::Location *bkgPictFile; short bkgResolution; bool filler_1; bool partialRendering; API_Rect partialRect; short scaleType; short bkgScaleType; Int32 filler_2[13]; } API_RendImage;
Members
- hSize
- Horizontal pixel size
- vSize
- Vertical pixel size
- outResolution
- Dots per inch resolution
- proportional
- Proportional change for
hSize/vSize
. - bkgPict
- Colors or picture background.
- bkgSkyRGB
- Sky color
- bkgEarthRGB
- Earth color
- bkgPictRect
- Background picture rectangle
- bkgPictFile
- Background picture file
- bkgResolution
- Background resolution
- partialRendering
- Photorender only a part of the whole image. The rectangular shape is defined by the
partialRect
field - partialRect
- Rectangle for partial photorendering; valid only if the
partialRendering
field istrue
. The position of the rectangle is relative to the left-top corner of the whole image - scaleType
- its value can be 0 (ScaleType_ToFill), or 1 (ScaleType_ToFit)
- bkgScaleType
- its value can be 0 (BKGScaleType_ToFit), 1 (BKGScaleType_ToFill), or 2 (BKGScaleType_Custom)
Remarks
This structure is used by the APIEnv_GetRenderingSetsID and APIEnv_ChangeRenderingSetsID functions to get and modify the settings of the Size & Background “Rendering Settings” tab page.
See an example of using this structure at the description of APIEnv_ChangeRenderingSetsID.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_GetRenderingSetsID, APIEnv_ChangeRenderingSetsID,
API_RendEffects, API_RGBColor, API_Rect, API Types