API_​RenovationStatusType

Renovation status of the (primitive) element.

    typedef enum {
        API_UndefinedStatus = -1,
        API_DefaultStatus = 0,
        API_ExistingStatus,
        API_NewStatus,
        API_DemolishedStatus
    } API_RenovationStatusType;

 

Members

API_UndefinedStatus
Certain element types (like cutplanes or drawings) don’t have any renovation status; this value indicates that.
API_DefaultStatus
Input-only pseudo-value; when you create or modify an element, Archicad will take the renovation status from the current element default.
API_ExistingStatus
One of the three pre-defined statuses; denotes an existing element.
API_NewStatus
One of the three pre-defined statuses; denotes an element created in the current phase.
API_DemolishedStatus
One of the three pre-defined statuses; denotes an element which should be demolished in the current phase.

 

Requirements

Version: API 15 or later
Header: APIdefs_Base.h

 

See Also

API_Prim_Head, API_Elem_Head
API Types