API_​RevolvedShellData

This structure holds the Revolved Shell specific data of API_ShellType.

    typedef struct {
        double                         slantAngle;
        double                         revolutionAngle;
        double                         distortionAngle;
        bool                           segmentedSurfaces;
        bool                           filler_1[3];
        API_ShellBaseSegmentTypeID     segmentType;
        Int32                          segmentsByArc;
        Int32                          segmentsByCircle;
        API_Polygon                    shellShape;
        API_Tranmat                    axisBase;
        API_Vector                     distortionVector;
        API_ContourEdgeData            begShapeEdgeData;
        API_ContourEdgeData            endShapeEdgeData;
        API_ContourEdgeData            revolvedEdgeDatas[2];
        double                         begAngle;
        bool                           filler_2[8];
    } API_RevolvedShellData;

 

Members

slantAngle
Relative to the plane (radians).
revolutionAngle
Angle of view (in radians).
distortionAngle
Angle of shear (radians).
segmentedSurfaces
The surface generated by revolving the profile is broken into planes along the revolution arc.
segmentType
Curve resolution method: by circle or by arc.
segmentsByArc
Number of actual segments if segmentType is APIShellBase_SegmentsByArc.
segmentsByCircle
Number of actual segments if segmentType is APIShellBase_SegmentsByCircle.
shellShape
Profile polygon specification to revolve. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo.
axisBase
Coord System of axis.
distortionVector
Direction of shear (in axisBase x-y plane)..
begShapeEdgeData
edge information for the starting plane of the shell
endShapeEdgeData
edge information for the end plane of the shell
revolvedEdgeDatas
edge information for the edges connecting points of the starting and end plane.
begAngle
Begin angle.

 

Remarks

For shell related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_ShellType, API_ShellBaseSegmentTypeID
API_Polygon, API_Tranmat
API_ContourEdgeData
API_ShellShapeData, API_ElementMemo
Element Manager, API Types