API_​RoofEdgeTypeId

Determines the type of the roof edges. This type is used just for listing purposes. It can be set individualy for each edge of the roof, the default value is Undefined.

    typedef enum {
        APIRoofEdgeType_Undefined,
        APIRoofEdgeType_Ridge,
        APIRoofEdgeType_Valley,
        APIRoofEdgeType_Gable,
        APIRoofEdgeType_Hip,
        APIRoofEdgeType_Eaves,
        APIRoofEdgeType_Peak,
        APIRoofEdgeType_SideWall,
        APIRoofEdgeType_EndWall,
        APIRoofEdgeType_RTDome,
        APIRoofEdgeType_RTHollow
    } API_RoofEdgeTypeID;

 

Members

APIRoofEdgeType_Undefined
The roof edge type is not set (default value).
APIRoofEdgeType_Ridge
The roof edge type is Ridge.
APIRoofEdgeType_Valley
The roof edge type is Valley.
APIRoofEdgeType_Gable
The roof edge type is Gable.
APIRoofEdgeType_Hip
The roof edge type is Hip.
APIRoofEdgeType_Eaves
The roof edge type is Eaves.
APIRoofEdgeType_Peak
The roof edge type is Peak.
APIRoofEdgeType_SideWall
The roof edge type is Side Wall.
APIRoofEdgeType_EndWall
The roof edge type is End Wall.
APIRoofEdgeType_RTDome
The roof edge type is Roof Transition – Dome.
APIRoofEdgeType_RTHollow
The roof edge type is Roof Transition – Hollow.

  

Requirements

Version: API 13 or later
Header: APIdefs_Elements.h

 

See Also

API_RoofType, API_EdgeTrim, API_ElementMemo, API Types, API_RoofQuantity