API_​RoofQuantity

Gives the different calculated values for roofs.

    typedef struct {
        double     bottomSurface;
        double     topSurface;
        double     edgeSurface;
        double     bottomSurface_cond;
        double     topSurface_cond;
        double     volume;
        double     volume_cond;
        double     perimeter;
        double     holesSurf;
        double     holesPrm;
        double     grossBotSurf;
        double     grossTopSurf;
        double     grossEdgeSurf;
        double     contourArea;
        double     grossVolume;
        double     insuThickness;
        double     ridgesLength;
        double     valleysLength;
        double     gablesLength;
        double     hipsLength;
        double     eavesLength;
        double     peaksLength;
        double     sideWallConLength;
        double     endWallConLength;
        double     domeConLength;
        double     hollowConLength;
        double     openingSurf;
        Int32      numOfHoles;
        Int32      numOfSkylight;
        Int32      filler_1;
        Int32      filler_2;
    } API_RoofQuantity;

 

Members

bottomSurface
bottom surface of the roof
topSurface
top surface of the roof
edgeSurface_cond
surface of the edge of the roof
bottomSurface_cond Changed in API 13
conditional bottom surface of the roof
topSurface Changed in API 13
conditional top surface of the roof
volume
volume of the roof
volume_cond Changed in API 13
conditional volume of the roof
perimeter
perimeter of the roof
holesSurf
total area of holes in the roof
holesPrm
total perimeter of holes in the roof
grossBotSurf
Gross surface of the roof bottom
grossTopSurf
Gross surface of the roof top
grossEdgeSurf
Gross surface of the roof edges
contourArea 15
The area of the roof contour polygon.
grossVolume
Gross volume of the roof
insuThickness Changed in API 13
roof insulation skin thickness
ridgesLength Changed in API 13
length of Ridge type edges divided by 2
valleysLength Changed in API 13
length of Valley type edges divided by 2
gablesLength Changed in API 13
length of Gable type edges
hipsLength Changed in API 13
length of Hip type edges divided by 2
eavesLength Changed in API 13
length of Eave type edges
peaksLength Changed in API 13
length of Peak type edges
sideWallConLength Changed in API 13
length of SideWall type edges
endWallConLength Changed in API 13
length of EndWall type edges
domeConLength Changed in API 13
length of RTDome type edges divided by 2
hollowConLength Changed in API 13
length of RTHollow type edges divided by 2
openingSurf 15
Sum of the surfaces of the roof openings.
numOfHoles 15
Number of holes in contour polygon.
numOfSkylight 15
Number of skylight.

 

Remarks

See also the roof parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types, API_RoofEdgeTypeId, API_CalcRulesPrefs