Describes various properties/parameters of a roof segment that can be separately adjusted. This structure is used in API_PivotPolyEdgeData.
typedef struct { double angle; API_LocalCoordsData lcoo; API_AttributeIndex topMaterial; API_AttributeIndex bottomMaterial; API_AttributeIndex coverFillType; Int32 filler_1; double eavesOverhang; API_PolyRoofSegmentAngleTypeID angleType; } API_RoofSegmentData;
Members
- angle
- Angle of the plane of the segment to the XY plane.
- lcoo
- Texture local coordinates data (see API_LocalCoordsData).
- topMaterial
- Top material of the roof segment.
- bottomMaterial
- Bottom material of the roof segment.
- coverFillType
- Fill of the top surface.
- eavesOverhang
- Eaves’ extension outside the pivot polygon.
- angleType
- The type of Segment. (see API_PolyRoofSegmentAngleTypeID)
Requirements
See ACAPI_Element_GetMemo to find out which element type needs/provides which information in the memo.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex, API_RoofType, API_PolyRoofData
API_PivotPolyEdgeData, API_LocalCoordsData
API_PolyRoofSegmentAngleTypeID
ACAPI_Element_GetMemo, API_ElementMemo
Element Manager, API Types