API_​RoofType

Represents a roof element.

    typedef struct {
        API_Elem_Head            head;
        API_RoofClassID          roofClass;
        Int32                    filler_1;
        API_ShellBaseType        shellBase;
        union {
            API_PlaneRoofData    planeRoof;
            API_PolyRoofData     polyRoof;
        } u;
    } API_RoofType;

 

Members

head
General element header.
shellBase
Parameters common with all shell-based element types.
roofClass
API_RoofClassID value Meaning
API_PlaneRoofID Single-plane roof, use the API_PlaneRoofData member of the union
API_PolyRoofID Multi-plane roof, use the API_PolyRoofData member of the union
u::planeRoof
Single-plane roof specific data.
u::polyRoof
Multi-plane roof specific data.

 

Remarks

For roof related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_Element
API_Sector, API_StoryVisibility, API_LinkToSettings
API_ElemDisplayOptionsID, API_ElemViewDepthLimitationsID
API_Polygon, API_ElementMemo
Element Manager, API Types