API_​RoomImage

Structure for retrieving data related to a room.

    typedef struct {
        API_Guid                  roomGuid;
        API_ImageViewID           viewType;
        double                    offset;
        double                    scale;
        API_RGBColor              backgroundColor;
        NewDisplay::NativeImage*  nativeImagePtr;
    } API_RoomImage;

 

Members

roomGuid
Identifier of the zone.
viewType
Currently not used, only the 2D image (Floor Plan) can be generated.
offset
Offset of the clip polygon from the edge of the zone.
scale
Scale of the view (e.g. 0.002 for 1:500).
backgroundColor
Background color of the generated image.
nativeImagePtr
Pointer to the output image (must be initialized before calling APIAny_GetRoomImageID).

 

Remarks

To learn more about the usage of the structure please refer to the APIAny_GetRoomImageID function.

 

Requirements

Version: API 23 or later
Header: APIdefs_Environment.h

 

See Also

APIAny_GetRoomImageID,
API Types