Parameters to get room reduction data.
typedef struct { short type; short percent; Int32 nCoords; Int32 nSubPolys; Int32 nArcs; API_Coord **coords; Int32 **subPolys; API_PolyArc **arcs; double area; Int32 filler_1[8]; } API_RoomReductionPolyType;
Members
- type
-
Type of the polygon.
type
polygon
APIRoomReduction_Wall
wall
APIRoomReduction_Column
column
APIRoomReduction_Hatch
hatch
APIRoomReduction_Gable
low ceil
APIRoomReduction_Rest
other
- percent
- Percentage of the polygon area
- nCoords
- Number of coordinates
- nSubPolys
- Number of the subpolygons
- nArcs
- Number of the arcs
- coords
- The coordinate array
- subPolys
- The subpolygon endpoints
- arcs
- The polygon arcs
- area
- Area of the polygon
Remarks
Refer to the API_Polygon structure to get more details on the polygon structure. See the RoomReductionPolyProc and APIDb_RoomReductionsID functions to get more information on the control how the room reduction data can be got.
Do not forget to dispose the data handles if they are not needed any more.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Database.h
See Also
RoomReductionPolyProc, APIDb_RoomReductionsID, API_Coord, API_PolyArc, API_Polygon, API Types