API_​RoomRelation

Structure for retrieving data related to a room.

    typedef struct {
        GS::HashTable<API_ElemType, GS::Array<API_Guid>>  elementsGroupedByType;
        GS::Array<API_WallPart>                           wallPart;
        GS::Array<API_BeamPart>                           beamPart;
        GS::Array<API_CWSegmentPart>                      cwSegmentPart;
        GS::Array<API_Niche>                              niches;
    } API_RoomRelation;

 

Members

elementsGroupedByType 24
Related elements of the room grouped by type. The keys in this table are the types and the values are the GUIDs of the elements with the given type.
wallPart 24
Wall parts that borders the room polygon
beamPart24 
Beam parts that related to the room.
cwSegmentPart 24 
Curtain Wall Segment parts that related to the room.
niches24 
Niches inside the room.

 

Remarks

Get the array’s size with it’s GetSize() function.

To learn more about the usage of the room relation structure please refer to the ACAPI_Element_GetRelations function.

New in API 26 From version 26 the type of the elementsGroupedByType member was changed into GS::HashTable<API_ElemType, GS::Array<API_Guid>>.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_WallPart, API_Niche, API_BeamPart, API Types