Rubber line definition.
typedef struct { API_Coord3D origC; bool radii; char filler[7]; API_RubberLineThickness lineThick; API_RubberArcTypeID arcType; union { struct { double r; double angle; double ratio; double begAng; double endAng; } arc2D; struct { API_Coord3D begC; API_Coord3D endC; bool sign; char filler[7]; } arc3D; }; Int32 filler_2[8]; } API_RubberArcType;
Members
- origC
- Coordinate of the center point
- radii
- Draw radii as well
- filler[7]
- Reserved for later use
- lineThick
- The thickness of the line, can be
APIRubberLine_Simple
orAPIRubberLine_Double
. - arcType
- The arc is defined with
arc2D
(used only in 2D) orarc3D
structure (APIRubberArc_OrigoAngles
orAPIRubberArc_ThreePoint
). - r
- Radius (or ‘a’ if ellipse)
- angle
- This value should be 0.0 in circle case or the angle of the ‘a’ axis of the ellipse
- ratio
- This value should be 1.0 in circle case or ‘a/b’ of the ellipse
- begAng
- Beginning angle of the arc
- endAng
- Ending angle of the arc
- begC
- Beginning point of the arc
- endC
- Ending point of the arc
- sign
- The arc’s angle is + (true) or – (false)
Remarks
See APIIo_DrawRubberArcID for utilization and example of API_RubberArcType
.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Interface.h
See Also
APIIo_DrawRubberArcID, RubberLineInfoProc, API_RubberLineInfo, API_Coord3D, API Types