API_​RubberLineInfo

Parameters of the rubber line callback function.

    typedef struct {
        API_Coord3D     actCoord;
        bool            drawFlag;
        char            filler_1;
        short           filler_2;
        Int32           filler_3[3];
    } API_RubberLineInfo;

 

Members

actCoord
The actual mouse coordinate
drawFlag
The callback function is called from drawing or deleting phase

 

Remarks

See RubberLineInfoProc for more information and the APIIo_DrawRubberLineID function for example of using the rubber line drawing callback function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

RubberLineInfoProc, APIIo_DrawRubberLineID, API_RubberLineType, API_Coord3D, API Types